We have updated our Terms of Service and Privacy Policy.
Dismiss

Jump to content


Renkotsu's Photo

Renkotsu

Member Since 03 Jul 2012
Offline Last Active Private

Posts I've Made

In Topic: Recent interview with Jagex CEO on Runescape and future Projects

02 April 2018 - 01:08 PM

Never heard about a succesful game made by Jagex outside RS tbh...maybe they change this time.

 
Hey man, Funorb was actually really great. It's a shame Jagex just let it rot after ~2010 :cry:


In Topic: I am the Bulwark Beast I Worship

23 December 2017 - 09:32 AM

A late congratulations and what perks do the Gold Premier package give?

 

Grazie <3 As far as gold premier goes, you just get an extra treasure hunter key a day, a full year's worth of membership, early access to whatever betas, stuff like that. Idk what benefits it has for OSR because I don't play that. Truth be told, I only got the gold because it the yearly on its own was only ~$10 cheaper so I figured I might as well spring for something nicer.


In Topic: Jeff Sessions seat sniped by a Democrat from a sexual predator

13 December 2017 - 09:04 PM

To quote the wise Ali Gomaa, former Grand Mufti of Egypt: "Roy Moore is a whore and so is his state."

 

Also, 2017 confirmed year of sexual assault allegations. Let's see if this keeps up in 2018.


In Topic: Demonic skull

26 November 2017 - 02:07 PM

That is really weird, so banking/relogging and the like still causes the glitch? I have a demonic skull and it seems to show up okay on mine on NXT (on low details), and from what I remember was fine on the legacy client as well. Hopefully they can get to the bottom of it and fix it!

 

hzbEFs6.png

 

I'm on NXT right now using the Legacy interface because it looks better when I split-screen it with Firefox. Legacy also seems to have issues with keybinds on the action bar. I can't activate my Tokkul-Zo or even any thresholds I have bound. Instead, the binds just show up on the chatbar. On top of that, enabling and disabling Legacy doesn't do jack ****.

 

Is it just me, or did RS3 somehow get buggier over the last couple of years?


In Topic: Demonic skull

23 November 2017 - 09:04 PM

Turns out it's a graphical glitch. The sprite is missing, but I can still hover over it. Seems to be exacerbated by playing on EOC/Legacy-only worlds, or perhaps low graphics detail?

 

Either way, still worthy of a bug report.


Font:
Arial | Calibri | Lucida Console | Verdana
 
Font Size:
9px | 10px | 11px | 12px | 10pt | 12pt
 
Color: